Vote Rewards

Vote Rewards 1.3b

No permission to download

Sacoor

New member
Messages
5
Likes
1
Points
3
Is 3 servers the max it will give points for? Because I'm running a full cluster with 5 Maps and people can just get a maximum of 30 points (10 per vote, per map) So the 4th and 5th key are not working.

Also, would it be possible to make /votereward give all rewards at once instead of having to type /votereward in chat 3,4,5 times. That would be a lot less tedious!

Thnx anyway, Loving the plugin! xoxo
 

fatgit

New member
Messages
19
Likes
2
Points
3
You can only vote on ark-servers.net 3 times a day anyway.
What we do is have the 3 servers for voting and use those 3 server keys on all maps (or we will once the plugin is fixed)

Is 3 servers the max it will give points for? Because I'm running a full cluster with 5 Maps and people can just get a maximum of 30 points (10 per vote, per map) So the 4th and 5th key are not working.

Also, would it be possible to make /votereward give all rewards at once instead of having to type /votereward in chat 3,4,5 times. That would be a lot less tedious!

Thnx anyway, Loving the plugin! xoxo
 

Modsouls

New member
Messages
17
Likes
1
Points
3
Since updating this plugin and updating ark-api to v2.7 my server crashes every time someone tries to claim their rewards, it was working beautifully beforehand. Do I need to generate a new ServerKey when an update is performed?
 

Nogen

New member
Messages
21
Likes
2
Points
3
That crash is not related to the plugin. Your server is hanging. Might be a perfomance issue.
No, it's the voterewards. The hang is from the /votereward and my system is "hanging" at command call

Thank you Michidu, Appreciate it, I just updated :)
 

Foppa

Moderator
Staff member
Messages
594
Likes
51
Points
28
Website
foppasgaming.com
No, it's the voterewards. The hang is from the /votereward and my system is "hanging" at command call

Thank you Michidu, Appreciate it, I just updated :)
No sorry, maybe I was a little bit too fast and unclear. Your crash stacks indicate something else. That's not related to the plugin or api.

Here is a crash stack for when the server is crashing after a votereward, you can see something with the API is involved since the second line and line after says "VERSION.dll" which is one of the files from the API.
Fatal error!



VERSION: 282.102
ShooterGameServer.exe!FHttpRequestWinInet::GetStatus() (0x00007ff6b4468aa0) + 0 bytes [d:\build\pc\engine\source\runtime\online\http\private\windows\httpwininet.cpp:724]
VERSION.dll!UnknownFunction (0x00007ffcae3e34a3) + 0 bytes [UnknownFile:0]
VERSION.dll!UnknownFunction (0x00007ffcae3c8996) + 0 bytes [UnknownFile:0]
ShooterGameServer.exe!FTimerManager::Tick() (0x00007ff6b475a177) + 0 bytes [d:\build\pc\engine\source\runtime\engine\private\timermanager.cpp:1080]
ShooterGameServer.exe!UWorld::Tick() (0x00007ff6b461646a) + 0 bytes [d:\build\pc\engine\source\runtime\engine\private\leveltick.cpp:1288]
ShooterGameServer.exe!UGameEngine::Tick() (0x00007ff6b45739bf) + 0 bytes [d:\build\pc\engine\source\runtime\engine\private\gameengine.cpp:1170]
ShooterGameServer.exe!FEngineLoop::Tick() (0x00007ff6b3318eac) + 0 bytes [d:\build\pc\engine\source\runtime\launch\private\launchengineloop.cpp:2421]
ShooterGameServer.exe!GuardedMain() (0x00007ff6b331481c) + 0 bytes [d:\build\pc\engine\source\runtime\launch\private\launch.cpp:140]
ShooterGameServer.exe!GuardedMainWrapper() (0x00007ff6b3319efa) + 5 bytes [d:\build\pc\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGameServer.exe!WinMain() (0x00007ff6b331a030) + 8 bytes [d:\build\pc\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGameServer.exe!__tmainCRTStartup() (0x00007ff6b5556df1) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007ffccbaa13d2) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffcce3354f4) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffcce3354f4) + 0 bytes [UnknownFile:0]
慌瑳删灥楬慣整⁤捁潴⁲慒湧牡歯䍟ㅟ਍慌瑳删浥瑯⁥畆据楴湯䌠楬湥䅴正潇摯潍敶਍

And your crash stack was pointing only on "ShooterGameServer.exe" and the first line clearly says: FHangThreadWatcher::HangeDetected()
So that can be something else, like a mod, something within ark or you have some performance issue with your server.

Hope it explains more this time :)

Fatal error!



VERSION: 282.102
ShooterGameServer.exe!FHangThreadWatcher::HangeDetected()(0x00000001410efa70)+0bytes[d:\build\pc\engine\source\runtime\engine\private\gameengine.cpp:169]
ShooterGameServer.exe!FHangThreadWatcher::Run()(0x00000001410ef9bc)+0bytes[d:\build\pc\engine\source\runtime\engine\private\gameengine.cpp:133]
ShooterGameServer.exe!FRunnableThreadWin::Run()(0x0000000140b58aff)+0bytes[d:\build\pc\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
ShooterGameServer.exe!FRunnableThreadWin::GuardedRun()(0x0000000140b589f8)+8bytes[d:\build\pc\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
kernel32.dll!UnknownFunction(0x0000000076d359cd)+0bytes[UnknownFile:0]
ntdll.dll!UnknownFunction(0x0000000076e9383d)+0bytes[UnknownFile:0]
ntdll.dll!UnknownFunction(0x0000000076e9383d)+0bytes[UnknownFile:0]
Last Replicated Actor FabledStyracosaurus_Character_BP_C_1
Last RemoteFunction Spike_Raise_Visual

Can someone help me with his config json file ? i always get errors and crashes would be rly nice other plugins work
Try run the config here first: https://jsonlint.com/ If you still have problems i can check on your config file.

Running Latest API: 2.71
I got this Error when i launch my Server

View attachment 700
That indicates that you have something wrong in your config file. At line 393 there is a syntax error in your config file, check it ;)
 
Messages
17
Likes
3
Points
3
There is no line 393 in the config.
but i removed the plugin already

managed the error:
if i try to add multiple items, it put out the error.
with just 1 item the server crash after i tpye /voterewards the second time.
i dont use the plugin anymore
 
Messages
17
Likes
3
Points
3
i tried vanilla config. just entered server-api keys.
if i type /voterewards i get the reward - fine

but if i type /votereward again, the server crashs
 
Messages
17
Likes
3
Points
3
Code:
{
  "ServerKey":"key1,key2",   ---> There are my API-Keys
  "ShopPoints":20,
  "Cooldown":3600,
  "ItemsConfig":{
    "Items":[
      {
        "Amount":1,
        "Quality":0,
        "ForceBlueprint":false,
        "Blueprint":"Blueprint'/Game/Mods/Primal_Fear/Weapons/Potions/XP/Small/PrimalItemConsumable_smallXP.PrimalItemConsumable_smallXP'"
      }
        "Amount":1,
        "Quality":0,
        "ForceBlueprint":false,
        "Blueprint":"Blueprint'/Game/Mods/Primal_Fear/Weapons/Potions/XP/Medium/PrimalItemConsumable_mediumXP.PrimalItemConsumable_mediumXP'"
      }
    ],
    "Dinos":[
      {
        "Level":10,
        "Blueprint":"Blueprint'/Game/Mods/Primal_Fear/Dinos/Fabled/Fabled_Jerboa/FabledJerboa_Character_BP.FabledJerboa_Character_BP'"
      }
    ]
  },
  "Messages":{
    "Sender":"Overseer",
    "Command":"/vote",
    "RequestFailed":"<RichColor Color=\"1, 0, 0, 1\">Server {}: Request has failed, please try again later</>",
    "VoteNotFound":"<RichColor Color=\"1, 0, 0, 1\">Server {}: Your vote wasn't found</>",
    "VoteClaimed":"<RichColor Color=\"1, 0, 0, 1\">Server {}: Your reward has already been claimed</>",
    "VoteNotClaimed":"<RichColor Color=\"1, 0, 0, 1\">Server {}: Your vote has not been claimed</>",
    "SuccessfullyClaimed":"<RichColor Color=\"0, 1, 0, 1\">Server {}: You have successfully claimed your reward</>",
    "CheckingVote":"Checking vote for server {0}..",
    "CooldownMsg":"<RichColor Color=\"1, 0, 0, 1\">Cooldown {} seconds</>"
  }
}
Latest Votereward and api version

I give this plugin a last try. If i take the config with 1 item and 1 dino, it works. but with multiple items it wont load
 
Last edited:

Herrow

New member
Messages
3
Likes
0
Points
1
Nice plugin! Can someone give me an example of a metal reward? (Like 1000). I would like an example with cementing paste too if possible (I already tried that, but the plugin didn't give the cementing paste reward, only the dino, the carno ahah)

Thanks for your time!
 
Last edited:

Melenia

New member
Messages
8
Likes
0
Points
1
I can confirm the plugin is not working since extinction patch, when you use the comand, the server insta crash.