Shop, Currency & Kits

Shop, Currency & Kits 2.8

No permission to download
Messages
30
Likes
4
Points
8
Can Someone help me? I am running a cluster server and all of a sudden getting error 126 when I boot my server. Each map has a different plugin not launch and they all say shop error 126.
 
Advertisement

Official Game Server Partner

01salocin

New member
Messages
7
Likes
1
Points
3
Hey guys how i can put this command

SpawnSetupDino <DinoBlueprintPath> <SaddleBlueprintPath> <SaddleQuality> <DinoLevel> <DinoStats> <SpawnDistance> <YOffset> <ZOffset>


EJ:
JSON:
cheat SpawnSetupDino "Blueprint'/Game/PrimalEarth/Dinos/Raptor/Raptor_Character_BP.Raptor_Character_BP'" "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/Saddles/PrimalItemArmor_RaptorSaddle.PrimalItemArmor_RaptorSaddle'" 1 80 "Health=30,MeleeDamageMultiplier=20,Weight=10" 500 500 0

that works well with things/ITEMS ?
 

Mako

New member
Messages
1
Likes
0
Points
1
Hello, forgive my ignorance. I add the folders to my server, and it always restarts. I have uploaded the API folder and the plugin.
What am I doing wrong?
 
Messages
51
Likes
2
Points
8
is there a way to make this has one entry so you can get the dinosaur and the saddle in one buy


"D1": {

"Type": "dino",
"Description": "Velonasaur",
"Level": 1500,
"Price": 1500,
"MinLevel": 75,
"MaxLevel": 115,
"Blueprint": "Blueprint'/Game/Extinction/Dinos/Spindles/Spindles_Character_BP.Spindles_Character_BP'"
},
"VS": {
"Type": "item",
"Description": "Velonasaur Saddle",
"Price": 500,
"Items": [{
"Quality": 1,
"ForceBlueprint": false,
"Amount": 1,
"Blueprint": "Blueprint'/Game/Extinction/CoreBlueprints/Items/Saddle/PrimalItemArmor_SpindlesSaddle.PrimalItemArmor_SpindlesSaddle'"
}]
}
},
 

toxxick

New member
Messages
19
Likes
0
Points
1
I am having 1 slight issue, after configuring the shop config file the way that I want, for some reason when i try the AddPoints command i get an error in-game (Ark) Couldn't Add Points. Anyone have this issue before if so how do you fix? Before you ask yes my config has been ran through several validators just to make sure.
 
Messages
51
Likes
2
Points
8
I am having 1 slight issue, after configuring the shop config file the way that I want, for some reason when i try the AddPoints command i get an error in-game (Ark) Couldn't Add Points. Anyone have this issue before if so how do you fix? Before you ask yes my config has been ran through several validators just to make sure.



are you using the command on Ark on or using the command in the game also to give points you need to steam 64-bit ID if you're trying to add points why in the game you need to add points using the Tap menu all commands must have cheat in front of them so it should look something like this (cheat AddPoints 6539605820685 1000) without the brackets
 

toxxick

New member
Messages
19
Likes
0
Points
1
Yea I have made sure it was the right command, exactly as u posted only with my steamID. Yes it was in-game using console commands. I have even tried a fresh installation of the Arkapi and shop still same results.
 

toxxick

New member
Messages
19
Likes
0
Points
1
are you using the command on Ark on or using the command in the game also to give points you need to steam 64-bit ID if you're trying to add points why in the game you need to add points using the Tap menu all commands must have cheat in front of them so it should look something like this (cheat AddPoints 6539605820685 1000) without the brackets

Yea I have made sure it was the right command, exactly as u posted only with my steamID. Yes it was in-game using console commands. I have even tried a fresh installation of the Arkapi and shop still same results.
 
Messages
51
Likes
2
Points
8
Yea I have made sure it was the right command, exactly as u posted only with my steamID. Yes it was in-game using console commands. I have even tried a fresh installation of the Arkapi and shop still same results.

I know this sounds stupid but it's a plug-in loaded try (cheat plugins.load ArkShop) I've had it happen once or twice where it doesn't load on Startup and then stays unloaded a good way to check to see if the mod is working is to use /shophelp in the chat window to see if you get a reply back
 

toxxick

New member
Messages
19
Likes
0
Points
1
Yea I have made sure it was the right command, exactly as u posted only with my steamID. Yes it was in-game using console commands. I have even tried a fresh installation of the Arkapi and shop still same results.

I think my issue was with the Tebex plugin, I am testing it now to see if that corrected the issue.
 
Messages
51
Likes
2
Points
8
I know this is a weird question but you didn't add any extra symbols or anything did you i ask I was trying to add something to the store earlier on my server and used (testing) in the description of one of the items and well did not like it but all the checkers I ran it through said it was okay by the way there is my favorite check or just FYI https://jsonlint.com/
 

toxxick

New member
Messages
19
Likes
0
Points
1
I know this is a weird question but you didn't add any extra symbols or anything did you i ask I was trying to add something to the store earlier on my server and used (testing) in the description of one of the items and well did not like it but all the checkers I ran it through said it was okay by the way there is my favorite check or just FYI https://jsonlint.com/

Yup same checker I use as well. No I created the entire config file for the first time. Ran it through the checker and corrected the mistakes (forgot the "Blueprint:" before each blueprint path), the .dll file in the arkshop folder does it store any id information? that was the only file it wouldn't let me delete from my server. So trying to get rid of it now to put a completely fresh shop in to see if something happen!

P.S I have used this dang shop for years and never seen this issue, kinda frustrating. But i guess this is how you really learn :)
 

toxxick

New member
Messages
19
Likes
0
Points
1
are you sure that the player you're trying to add points to is in the database?

Yes my server is locked due to being worked on. I have been trying to test it on myself. Also I have deleted the DB file just to be sure that a fresh one is created with no issues. I have checked and I am the only 1 in the db file. I am about to see if I manually edit the db file if it will recognize the points were added. I will post my results in few minutes

UPDATE: So I have litterally uninstalled my entire server and started from scratch, and still getting the same error! If anyone else have anymore Ideas I am willing to try, i just want this shop to work.
 
Last edited:
Messages
17
Likes
3
Points
3
Hey guys how i can put this command

SpawnSetupDino <DinoBlueprintPath> <SaddleBlueprintPath> <SaddleQuality> <DinoLevel> <DinoStats> <SpawnDistance> <YOffset> <ZOffset>


EJ:
JSON:
cheat SpawnSetupDino "Blueprint'/Game/PrimalEarth/Dinos/Raptor/Raptor_Character_BP.Raptor_Character_BP'" "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/Saddles/PrimalItemArmor_RaptorSaddle.PrimalItemArmor_RaptorSaddle'" 1 80 "Health=30,MeleeDamageMultiplier=20,Weight=10" 500 500 0

Yoy team, can update for this command?
 
Top