Shop, Currency & Kits

Shop, Currency & Kits 2.8

No permission to download
Advertisement

Official Game Server Partner

McAbraxus

New member
Messages
7
Likes
0
Points
1
Hello my friend little question.
i use SQL and when players go in server they get default and if they make command /kits they get the default kits, but
for some reason, that dont show on database, the points are ok the steam ID to but not the kits, is not always but most time kits colun is empty, any ideia ?

thanks
The kits aren't written to the database, until they are used. You can manually add them or add to them though.
 

djyohan

New member
Messages
2
Likes
0
Points
1
Hello all .. New to this so bear with me please.
I have the following issue . Set the parameters like below so i dont want to give away some kits for free , when type in /buykit TekArmorSet 1 the points are taken from player but no item given. If i change the Default amount for 2 the 2 free sets are given but after only points taken again and no kit given. What did i do wrong?

},
"TekArmorSet": {
"Permissions": "Default",
"DefaultAmount":0,
"Price": 2000,
"MinLevel": 1,
"MaxLevel": 900,
"OnlyFromSpawn": false,
"Description": "Set of tek armor (leggings,chest piece,gauntlet,helmet,boots and 10 elements)",
"Items": [{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekBoots.PrimalItemArmor_TekBoots'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekGloves.PrimalItemArmor_TekGloves'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekHelmet.PrimalItemArmor_TekHelmet'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekPants.PrimalItemArmor_TekPants'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekShirt.PrimalItemArmor_TekShirt'"
},
{
"Amount": 10,
"Quality": 0,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Resources/PrimalItemResource_Element.PrimalItemResource_Element_C'"
}
]
}
},

Thanks in advance
 
Messages
31
Likes
2
Points
8
Hello all .. New to this so bear with me please.
I have the following issue . Set the parameters like below so i dont want to give away some kits for free , when type in /buykit TekArmorSet 1 the points are taken from player but no item given. If i change the Default amount for 2 the 2 free sets are given but after only points taken again and no kit given. What did i do wrong?

},
"TekArmorSet": {
"Permissions": "Default",
"DefaultAmount":0,
"Price": 2000,
"MinLevel": 1,
"MaxLevel": 900,
"OnlyFromSpawn": false,
"Description": "Set of tek armor (leggings,chest piece,gauntlet,helmet,boots and 10 elements)",
"Items": [{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekBoots.PrimalItemArmor_TekBoots'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekGloves.PrimalItemArmor_TekGloves'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekHelmet.PrimalItemArmor_TekHelmet'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekPants.PrimalItemArmor_TekPants'"
},
{
"Amount": 1,
"Quality": 5,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/TEK/PrimalItemArmor_TekShirt.PrimalItemArmor_TekShirt'"
},
{
"Amount": 10,
"Quality": 0,
"ForceBlueprint": false,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Resources/PrimalItemResource_Element.PrimalItemResource_Element_C'"
}
]
}
},

Thanks in advance
if you have read the guide, when a kit is bought the user has x amount of the kit, he needs to use /kit kitname to redeem it
 

isthattay

New member
Messages
10
Likes
0
Points
1
Having issues seeing my BUYIDS, actual IDs from the file WORK the problem is the players see these sequential numbers so they have to look in my F1 info to get real IDs. Any Ideas? I even tried switching to mysql thinking a new DB would clear it up but it brought these numbers with them. Will list section of code that's relevant to screencap - all items do this though.


},
"mindwipe": {
"Type": "item",
"Description": "Mindwipe",
"Price": 60,
"Items": [{
"Quality": 0,
"ForceBlueprint": false,
"Amount": 1,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Consumables/BaseBPs/PrimalItemConsumableRespecSoup.PrimalItemConsumableRespecSoup'"
}]
},
"element": {
"Type": "item",
"Description": "Element (100x)",
"Price": 350,
"Items": [{
"Quality": 0,
"ForceBlueprint": false,
"Amount": 100,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Resources/PrimalItemResource_Element.PrimalItemResource_Element'"
}]
},
"ingots100": {
"Type": "item",
"Description": "Metal Ingot (100x)",
"Price": 15,
"Items": [{
"Quality": 0,
"ForceBlueprint": false,
"Amount": 100,
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Resources/PrimalItemResource_MetalIngot.PrimalItemResource_MetalIngot'"
}]
 

Attachments

djyohan

New member
Messages
2
Likes
0
Points
1
if you have read the guide, when a kit is bought the user has x amount of the kit, he needs to use /kit kitname to redeem it
HMMM thats not issue i was referring to...The free kits are ok to use .... after when you want to buy of those and NO FREE left the items not given but points are taken
 
Messages
1
Likes
0
Points
1
Is there anyone that can help me out?

Ive tried to edit my config for days now,

I have 0 Json errors, and the plugin does load in.

The starter kit works, but the shop doesent seem to work.. Whenever i do /shop, nothing happens, and the server just freezes until it eventually crashes, i dont know how to fix this issue, but if anyone does, pls help me out. Thank you sm. :)
 

Attachments

Messages
31
Likes
2
Points
8
HMMM thats not issue i was referring to...The free kits are ok to use .... after when you want to buy of those and NO FREE left the items not given but points are taken
when someone buys the kit they get the ability to use that kit for x amount of times they bought the kit

for example

JSON:
        "starter_argy":{
            "DefaultAmount":2,
            "Price":50,
            "Description":"Starter kit (argie with saddle)",
            "OnlyFromSpawn":false,
            "Items":[
                {
                    "Amount":1,
                    "Quality":0,
                    "ForceBlueprint":false,
                    "Blueprint":"Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Armor/Saddles/PrimalItemArmor_ArgentavisSaddle.PrimalItemArmor_ArgentavisSaddle'"
                }
            ],
            "Dinos":[
                {
                    "Level":75,
                    "Blueprint":"Blueprint'/Game/PrimalEarth/Dinos/Argentavis/Argent_Character_BP.Argent_Character_BP'"
                }
            ]
        },
This particular code gives someone a default amount of kits (2 in this case) with the option to buy more for the price of 50 points.
So when someone uses the command "/kit" they would see a list of available kits, the amount they have, and their price, in this case would be 2 available kits

When they use the command "/kit starter_argy" they would use one of their available kits, in this case the dino would spawn and the saddle would be in their inventory, and a message ingame would say they used the kit and would have x amount left

Otherwise if this isnt the explanation you wanted you should provide a more extensive detailed question
 
Messages
31
Likes
2
Points
8
Is there anyone that can help me out?

Ive tried to edit my config for days now,

I have 0 Json errors, and the plugin does load in.

The starter kit works, but the shop doesent seem to work.. Whenever i do /shop, nothing happens, and the server just freezes until it eventually crashes, i dont know how to fix this issue, but if anyone does, pls help me out. Thank you sm. :)
I saw you DM me, i replied
 
Messages
31
Likes
2
Points
8
Anyone have an idea why buy IDs would show numerical numbers?

for example /shop shows 23 for element and not "element". . . but it only works if you type /buy element 1 so the file knows what is correct.
JSON:
        "1":{
            "Type":"item",
            "Description":"Element x 1",
            "Price":1000,
            "Items":[
                {
                    "Quality":0,
                    "ForceBlueprint":false,
                    "Amount":1,
                    "Blueprint":"Blueprint'/Game/PrimalEarth/CoreBlueprints/Resources/PrimalItemResource_Element.PrimalItemResource_Element_C'"
                }
            ]
        },
Im pretty sure your code is like this, if it is you need to change the following

Code:
        "1 change this line here to whatever you want this is the id":{
            "Type":"item",
            "Description":"Element x 1",
 
Top