HANG DETECTED on map with plugins 3x since install

KatKilmowski

Member
Donators
Messages
75
Likes
6
Points
8
Has anyone ever received a HANG DETECTED error using any plugins?

I have a windows server 2016 dedicated server, i7-7700K OC, 4c/8t, 4.7ghz/5ghz, 64gb ddr4 2400 mhz, softraid 2x450gb NVme.

I have 6 maps. 5 don't have the plugins. One does. There are two people testing on it, never at the same time. Brand new server and maps, no users otherwise.

I set it up about a week ago, and I have received HANG DETECTED 3x since setup. When no one is using it basically: 6PM, 12AM, 4PM.

I am using:
ArkShop
Lottery
NewPlayerProtection
ShopRewards

the errors look like this just before:
[2019.02.14-04.58.15:104][647]LogMemory: Platform Memory Stats for WindowsServer
[2019.02.14-04.58.15:104][647]LogMemory: Process Physical Memory: 4104.47 MB used, 4104.47 MB peak
[2019.02.14-04.58.15:104][647]LogMemory: Process Virtual Memory: 4169.18 MB used, 6423.38 MB peak
[2019.02.14-04.58.15:104][647]LogMemory: Physical Memory: 24633.61 MB used, 65402.55 MB total
[2019.02.14-04.58.15:104][647]LogMemory: Virtual Memory: 4619.10 MB used, 134217728.00 MB total
[2019.02.14-05.13.34:049][647]!!!HANG DETECTED!!!
[2019.02.14-05.13.34:595][647] - FPlatformMisc::RequestExit(1)

I have 64GB memory.
36% memory usage is around where it sits.

Island is where I am testing. It is on 103MB memory usage now. But was on 4000MB yesterday when I checked it. Don't know why it has that kind of fluctuation.

Could any of this be due to a plugin?

I am using 3 mods: S+, Utilities Plus, and StackMeMore 1.51 (the one taken over by a new author and revamped).

thanks!

Kat
 
Advertisement

Official Game Server Partner

Foppa

Moderator
Staff member
Messages
688
Likes
64
Points
28
Website
foppasgaming.com
Has anyone ever received a HANG DETECTED error using any plugins?

I have a windows server 2016 dedicated server, i7-7700K OC, 4c/8t, 4.7ghz/5ghz, 64gb ddr4 2400 mhz, softraid 2x450gb NVme.

I have 6 maps. 5 don't have the plugins. One does. There are two people testing on it, never at the same time. Brand new server and maps, no users otherwise.

I set it up about a week ago, and I have received HANG DETECTED 3x since setup. When no one is using it basically: 6PM, 12AM, 4PM.

I am using:
ArkShop
Lottery
NewPlayerProtection
ShopRewards

the errors look like this just before:
[2019.02.14-04.58.15:104][647]LogMemory: Platform Memory Stats for WindowsServer
[2019.02.14-04.58.15:104][647]LogMemory: Process Physical Memory: 4104.47 MB used, 4104.47 MB peak
[2019.02.14-04.58.15:104][647]LogMemory: Process Virtual Memory: 4169.18 MB used, 6423.38 MB peak
[2019.02.14-04.58.15:104][647]LogMemory: Physical Memory: 24633.61 MB used, 65402.55 MB total
[2019.02.14-04.58.15:104][647]LogMemory: Virtual Memory: 4619.10 MB used, 134217728.00 MB total
[2019.02.14-05.13.34:049][647]!!!HANG DETECTED!!!
[2019.02.14-05.13.34:595][647] - FPlatformMisc::RequestExit(1)

I have 64GB memory.
36% memory usage is around where it sits.

Island is where I am testing. It is on 103MB memory usage now. But was on 4000MB yesterday when I checked it. Don't know why it has that kind of fluctuation.

Could any of this be due to a plugin?

I am using 3 mods: S+, Utilities Plus, and StackMeMore 1.51 (the one taken over by a new author and revamped).

thanks!

Kat
Hang can be caused by anything, sometimes by mods. Never have I experienced that a plugin would cause a hang though. but you are running 6 servers on 4 cores and that could be the reason. And you have clocked your CPU quite high and that increases the chance for anything to hang.

And why the memory can go down to around 100-200mb is cause it hibernates when no ones are actively playing. So that's not a strange thing :)

But my suggestion would be either reduce the number of ark servers you are running or try lower down your overclocking until you find the sweet spot. And troubleshoot with Aida64.
 
Top