Solved Game Crashes after installing API

Status
Not open for further replies.

cmontoro

New member
Messages
2
Likes
0
Points
1
Api seems to load just fine:

02/10/19 03:10 [API][info] -----------------------------------------------
02/10/19 03:10 [API][info] ARK: Server Api V3.0
02/10/19 03:10 [API][info] Loading...

02/10/19 03:10 [API][info] Dumping structures..
02/10/19 03:10 [API][info] Dumping functions..
02/10/19 03:10 [API][info] Dumping globals..
02/10/19 03:10 [API][info] Successfully read information from PDB

02/10/19 03:10 [API][error] Failed to create hook for APlayerController.ConsoleCommand
02/10/19 03:10 [API][info] Initialized hooks

02/10/19 03:10 [API][info] API was successfully loaded
02/10/19 03:10 [API][info] -----------------------------------------------




But then when the game actually starts loading after API, it crashes:


Fatal error!



VERSION: 0.0
ShooterGame.exe!Z_Construct_UFunction_UPawnActionsComponent_AbortAction() (0x00007ff739193bf4) + 323 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:2407]
ShooterGame.exe!Z_Construct_UClass_UPawnActionsComponent() (0x00007ff739194d51) + 5 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:2506]
ShooterGame.exe!Z_Construct_UScriptStruct_UPawnActionsComponent_FPawnActionEvent() (0x00007ff739193356) + 5 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:2377]
ShooterGame.exe!FPawnActionEvent::StaticStruct() (0x00007ff739185b81) + 33 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:180]
ShooterGame.exe!UObjectLoadAllCompiledInStructs() (0x00007ff738d593ef) + 62 bytes [f:\build\trunk\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:766]
ShooterGame.exe!ProcessNewlyLoadedUObjects() (0x00007ff738d594ec) + 0 bytes [f:\build\trunk\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:785]
ShooterGame.exe!FEngineLoop::preInit() (0x00007ff737c96c1d) + 0 bytes [f:\build\trunk\engine\source\runtime\launch\private\launchengineloop.cpp:1454]
ShooterGame.exe!GuardedMain() (0x00007ff737c92e49) + 8 bytes [f:\build\trunk\engine\source\runtime\launch\private\launch.cpp:112]
ShooterGame.exe!GuardedMainWrapper() (0x00007ff737c9a0ba) + 5 bytes [f:\build\trunk\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGame.exe!WinMain() (0x00007ff737c9a1e8) + 8 bytes [f:\build\trunk\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGame.exe!__tmainCRTStartup() (0x00007ff73a782ba1) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007fff0ce03034) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff0eff3691) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff0eff3691) + 0 bytes [UnknownFile:0]


Removing the only plugin I had installed did not fix the problem, however removing the API installation files made the server work again.

Any solution for this issue?

Thanks in advance.
 
Advertisement

Official Game Server Partner

Foppa

Moderator
Staff member
Messages
713
Likes
65
Points
28
Website
foppasgaming.com
Api seems to load just fine:

02/10/19 03:10 [API][info] -----------------------------------------------
02/10/19 03:10 [API][info] ARK: Server Api V3.0
02/10/19 03:10 [API][info] Loading...


02/10/19 03:10 [API][info] Dumping structures..
02/10/19 03:10 [API][info] Dumping functions..
02/10/19 03:10 [API][info] Dumping globals..
02/10/19 03:10 [API][info] Successfully read information from PDB


02/10/19 03:10 [API][error] Failed to create hook for APlayerController.ConsoleCommand
02/10/19 03:10 [API][info] Initialized hooks


02/10/19 03:10 [API][info] API was successfully loaded
02/10/19 03:10 [API][info] -----------------------------------------------




But then when the game actually starts loading after API, it crashes:


Fatal error!



VERSION: 0.0
ShooterGame.exe!Z_Construct_UFunction_UPawnActionsComponent_AbortAction() (0x00007ff739193bf4) + 323 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:2407]
ShooterGame.exe!Z_Construct_UClass_UPawnActionsComponent() (0x00007ff739194d51) + 5 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:2506]
ShooterGame.exe!Z_Construct_UScriptStruct_UPawnActionsComponent_FPawnActionEvent() (0x00007ff739193356) + 5 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:2377]
ShooterGame.exe!FPawnActionEvent::StaticStruct() (0x00007ff739185b81) + 33 bytes [f:\build\trunk\projects\shootergame\intermediate\build\win64\shootergame\inc\aimodule\aimodule.generated.cpp:180]
ShooterGame.exe!UObjectLoadAllCompiledInStructs() (0x00007ff738d593ef) + 62 bytes [f:\build\trunk\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:766]
ShooterGame.exe!ProcessNewlyLoadedUObjects() (0x00007ff738d594ec) + 0 bytes [f:\build\trunk\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:785]
ShooterGame.exe!FEngineLoop::preInit() (0x00007ff737c96c1d) + 0 bytes [f:\build\trunk\engine\source\runtime\launch\private\launchengineloop.cpp:1454]
ShooterGame.exe!GuardedMain() (0x00007ff737c92e49) + 8 bytes [f:\build\trunk\engine\source\runtime\launch\private\launch.cpp:112]
ShooterGame.exe!GuardedMainWrapper() (0x00007ff737c9a0ba) + 5 bytes [f:\build\trunk\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGame.exe!WinMain() (0x00007ff737c9a1e8) + 8 bytes [f:\build\trunk\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGame.exe!__tmainCRTStartup() (0x00007ff73a782ba1) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007fff0ce03034) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff0eff3691) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007fff0eff3691) + 0 bytes [UnknownFile:0]


Removing the only plugin I had installed did not fix the problem, however removing the API installation files made the server work again.

Any solution for this issue?

Thanks in advance.
Are you trying to install the API on your game client? if so that's not supported. You have to install it on a dedicated server.
 
Status
Not open for further replies.
Top