Cross Server Chat

Cross Server Chat 1.0

No permission to download

Shadowsong

Member
Donators
Messages
89
Likes
14
Points
8
Is it possible to make it show the Grid it's in instead of "Ocean"

Since all my servers run on 1 machine, I can only add the plugin once so I cannot manually edit the "CrossChatMapNameOverride" because it would show the same for all.
Is the cross chat working ok for you? How many servers are you running it on?
 
Advertisement

Official Game Server Partner

freekill

Member
Donators
Messages
53
Likes
3
Points
8
Website
discord.gg
Nice, not had any issues with it shortening names or crashing? Also what hardware are you running on that server, just out of interest!
Haven't seen those issues yet.

CPU: Intel i7-7700K OC - 4c/8t - 4.7GHz /5GHz
RAM: 64GB DDR4 2400 MHz8
Disks: SoftRaid 2x450GB NVMe
Traffic: 250 Mpbsbandwith(burst 1 Gbps) unlimited
OS: Windows Server 2016 Standard

I do have my server tickrate on 10. Any higher and my CPU usage will be too high
 

Shadowsong

Member
Donators
Messages
89
Likes
14
Points
8
@freekill

Ah ok, i was finding that certain names were shortened, surnames mainly.

How many players do you have online at peak, do you find it running ok? I'm currently running 9 grids on Server 2019, i9900K and 64GB of memory. But i am using a tick rate of 20.

My servers currently allow 100 people per grid, but i worry that even that would be a struggle if they were near full so haven't thought much about going to a larger grid.

How is your memory usage? My grids are fairly packed with islands, but find that all of them are 4GB+, couple near 5GB. Don't think i'd ever manage 16 grids unless i could really drop the memory usage per grid.
 
Last edited:

docjones

Member
Donators
Messages
32
Likes
9
Points
8
16 grid ?? really ?.
mine 3x2 = 6 grid, , i7700k ,64gb 3200mhz,, not OC becouse not diference, m2 NVMe , 2016 server, tickrate=10 , and 96% cpu...

cpu.jpg
 

freekill

Member
Donators
Messages
53
Likes
3
Points
8
Website
discord.gg
16 grid ?? really ?.
mine 3x2 = 6 grid, , i7700k ,64gb 3200mhz,, not OC becouse not diference, m2 NVMe , 2016 server, tickrate=10 , and 96% cpu...

View attachment 1153
Go to "AtlasInstalLocation\ShooterGame\Config" and open up DefaultEngine.ini
Search for "[/Script/OnlineSubsystemUtils.IpNetDriver]"
and add the following line to it:
NetServerMaxTickRate=10

Since you only have 3x2, you can also use 15 instead of 10
 

docjones

Member
Donators
Messages
32
Likes
9
Points
8
Go to "AtlasInstalLocation\ShooterGame\Config" and open up DefaultEngine.ini
Search for "[/Script/OnlineSubsystemUtils.IpNetDriver]"
and add the following line to it:
NetServerMaxTickRate=10
Since you only have 3x2, you can also use 15 instead of 10
I have NetServerMaxTickRate=10..., maybe the problem is that i have 150-180 players online...
server optimization needed..
 

docjones

Member
Donators
Messages
32
Likes
9
Points
8
with 20-30ppl, it's about 17-19% cpu each node.
with 50 ppl it's about >=20% cpu each node, and more higher, becouse i have 6 grids.. and cpu it's doing bottleneck at 96%-100%., each grid need at least two threads.
More islands in each grid = more memory usage per grid. U need balance the grid size, memory avaliable, and islands in each grid, i have about 12-15 islands en each grid, 6-8gb usage each, and about 46gb total memory used.
Pd: Sorry for the offtopic.
 

Shadowsong

Member
Donators
Messages
89
Likes
14
Points
8
with 20-30ppl, it's about 17-19% cpu each node.
with 50 ppl it's about >=20% cpu each node, and more higher, becouse i have 6 grids.. and cpu it's doing bottleneck at 96%-100%., each grid need at least two threads.
More islands in each grid = more memory usage per grid. U need balance the grid size, memory avaliable, and islands in each grid, i have about 12-15 islands en each grid, 6-8gb usage each, and about 46gb total memory used.
Pd: Sorry for the offtopic.
Ok thanks for the info, what's your thoughts on a 3x4 grid running on a 9900k @5Ghz (8 cores/16 threads)? Would have a cap of 50 players per grid, though its unlikely to get that busy. I will be running a 15 tick rate and it is a long term server for a community so i'm hoping further CPU optimisations will come down with patching.

Also more on topic - Are you using cross server chat and does it work ok with the number of players on your grids?
 

docjones

Member
Donators
Messages
32
Likes
9
Points
8
50pl x 12 grid =600pl it's too much. , may be with 20-30ppl in each grid you probably stay in 80-90% cpu., each configuration grid it's diferrent.. i have a lot of islands (12-15 each node)., may be with < island's goes better.
At the beginning the cells do not consume much cpu, but when there are more built structures and players building, the cpu consumption rises a lot.

i must disable crosschat, too many pople chatting, and i'm not sure, but i think that some servers crash are related to crosschat,, then i had to disable it.
 

Shadowsong

Member
Donators
Messages
89
Likes
14
Points
8
50pl x 12 grid =600pl it's too much. , may be with 20-30ppl in each grid you probably stay in 80-90% cpu., each configuration grid it's diferrent.. i have a lot of islands (12-15 each node)., may be with < island's goes better.
At the beginning the cells do not consume much cpu, but when there are more built structures and players building, the cpu consumption rises a lot.

i must disable crosschat, too many pople chatting, and i'm not sure, but i think that some servers crash are related to crosschat,, then i had to disable it.
Yea did think that maybe the case, but i think it will be a close thing so going to try it! One of my grids will be Center Maw so no building at all and the other grids will be 6-7 islands max, so hopefully those two factors, plus future optimisations may help!

Good to know with cross chat, was going to try it again but i don't want to relaunch with a bunch of crashes.
 
Messages
218
Likes
13
Points
18
Website
steamcommunity.com
To get this back on topic... Does this still only work for grids on the same server? Im running a 6x6 on 4 machines.

EDIT: It appears to not be the case since its using RCON to get and send chat.
 
Last edited:

GeekGoggles

Member
Donators
Messages
125
Likes
9
Points
18
i would like to know this as well. I can't seem to get this working at all. If someone that got it working can tell me what i might be doing wrong?

1. placed plugin into plugin folder
2. configured plugin with key, ips and ports (tried 127.0.0.1 and the port as Its all 1 server, also tried the public IP)
3. started server
4. message displays that the IPs were added and configured within server console.
5. typed a standard global message in game, and it sends as a normal message.. not as a server wide

any ideas what I'm doing wrong?
Same issue here I had this working on my Ark 6 cluster. But with Atlas I have all servers in one folder meaning they all read the same plugins folder! Still can't get this one working. All my other plugins work fine across all 6 Servers though!
 
Top