Cross Server Chat

Cross Server Chat 1.7

No permission to download

gemnewton

New member
Messages
5
Likes
0
Points
1
Hello everyone,

Struggling to get this to work, so all 3 of my servers are clustered.

I have installed API (through the host) and extracted the plugin to the correct place on every server.

The config I used on every server is:

{
"CrossChatKey":"newtark",
"CrossChatMapNameInclude":true,
"RconServers":[
"145.239.104.194:7878",
"79.137.113.196:7878",
"79.137.113.199:7778"
],
"CrossChatMapNameOverride":"",
"Async":true
}

This is identically set up on each server on the cluster - however, nothing happens, the chat is the same as normal.

All my setting for RCON is enabled etc.

My server is hosted with tcadmin on Craft and Survive, I have asked them however they are not sure.

Are there any other settings I need to check? Once I extracted the plugin all I have edited is the config.json and nothing else - nothing on the API either.

Thank you :)
 
Advertisement

Monetise Your Game Server

Want to monetise your ARK Server? Create your own webstore at tebex.io

Messages
3
Likes
0
Points
1
OwnProx submitted a new resource:

Cross Server Chat using RCON - Send in game chat messages to all your servers



Read more about this resource...
Im having trouble getting this to work as well.
Im running a 6 server cluster with ASM (Ark Server Manager)
RCON is enabled and port forwarded on 32330 only

C:\Servers\Server1\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Abberation",
"Async":true
}

C:\Servers\Server2\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"The Center",
"Async":true
}

C:\Servers\Server3\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"TheIsland",
"Async":true
}

C:\Servers\Server4\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Extinction",
"Async":true
}

C:\Servers\Server5\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Ragnarok",
"Async":true
}

C:\Servers\Server6\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Scorched Earth",
"Async":true
}

Do an need to open an RCON port per server or can they all share the same rcon port?
Please advise.
 

WETBATMAN

Active member
Plugin Developer
Donators
Messages
222
Likes
59
Points
28
Website
dopeark.com
Hello everyone,

Struggling to get this to work, so all 3 of my servers are clustered.

I have installed API (through the host) and extracted the plugin to the correct place on every server.

The config I used on every server is:

{
"CrossChatKey":"newtark",
"CrossChatMapNameInclude":true,
"RconServers":[
"145.239.104.194:7878",
"79.137.113.196:7878",
"79.137.113.199:7778"
],
"CrossChatMapNameOverride":"",
"Async":true
}

This is identically set up on each server on the cluster - however, nothing happens, the chat is the same as normal.

All my setting for RCON is enabled etc.

My server is hosted with tcadmin on Craft and Survive, I have asked them however they are not sure.

Are there any other settings I need to check? Once I extracted the plugin all I have edited is the config.json and nothing else - nothing on the API either.

Thank you :)
your setup will never work because you’re using game ports instead of rcon 😃
 
Messages
3
Likes
0
Points
1
Im having trouble getting this to work as well.
Im running a 6 server cluster with ASM (Ark Server Manager)
RCON is enabled and port forwarded on 32330 only

C:\Servers\Server1\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Abberation",
"Async":true
}

C:\Servers\Server2\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"The Center",
"Async":true
}

C:\Servers\Server3\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"TheIsland",
"Async":true
}

C:\Servers\Server4\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Extinction",
"Async":true
}

C:\Servers\Server5\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Ragnarok",
"Async":true
}

C:\Servers\Server6\ShooterGame\Binaries\Win64\ArkApi\Plugins\config.json
{
"CrossChatKey":"1",
"CrossChatMapNameInclude":true,
"RconServers":[
"127.0.0.1:32330",
"127.0.0.1:32301"
],
"CrossChatMapNameOverride":"Scorched Earth",
"Async":true
}

Do i need to open an RCON port per server or can they all share the same rcon port?
Please advise.

FIXED IT!
I was able to fix my issues with the help of friends.

This works (After)
I had to replace the loopback address with the static private IP on the server
192.168.1.118 (local ip on the machine not the WAN ip on the router)
I had to make sure to save the .json config file in UTF-8 (it defaults to ANSI) for each server in each .json file
I had to copy the .rar into the plugins folder and extract it into its own folder in the plugins folder
C:\Servers\Server1\ShooterGame\Binaries\Win64\ArkApi\Plugins\RconCrossServerChat

{
"CrossChatKey":"IMAKEY",
"CrossChatMapNameInclude":true,
"RconServers":[
"192.168.1.118:32300",
"192.168.1.118:32301",
"192.168.1.118:32302",
"192.168.1.118:32303",
"192.168.1.118:32304",
"192.168.1.118:32305"
],
"CrossChatMapNameOverride":"",
"Async":true
}
 

Kicore

New member
Messages
4
Likes
0
Points
1
I have read every page of this discussion and I'm still not having any success with it working. I use Host Havoc and have successfully gotten the folder to the correct locations on both servers through ftp transfer.

These are the current settings I have

{
"CrossChatKey":"TinyTribes",
"CrossChatMapNameInclude":true,
"RconServers":[
"173.234.27.85:27057",
"173.234.27.85:27066"
],
"CrossChatMapNameOverride":"",
"Async":true
}




Based on the fact that I'm seeing

05/02/19 10:20 [RconCrossServerChat][info] 173.234.27.85:27057 Rcon Server Added.
05/02/19 10:20 [RconCrossServerChat][info] 173.234.27.85:27066 Rcon Server Added.
05/02/19 10:20 [API][info] Loaded plugin RconCrossServerChat V1.7 (Cross Server chat using RCON)


it appears that it's working correctly, but when I send a message by using the enter key, there is no indicator that the message is broadcast to the other sever. I would think it would show The Island or Scorched Earth next to my name or tribe-name when sending the message from the respective maps. The server is hosted through hosthavoc and they use a windows based server to my knowledge, and I have already ensured that I'm using the UTF-8 format that others had overlooked, and I would have too, had I not read every message in this discussion first. Any guidance would be very much appreciated.

P.S. RCON for the servers have been verified to be 27057 and 27066 through the gus.ini


EDIT: So it was working this entire time... You just don't have a way of knowing if it works unless other players are on the other server and my dumb self was testing it by myself. Super easy to install!
 
Last edited:

Yetisteven

New member
Messages
25
Likes
2
Points
3
So i'm not sure what the issue is here, my ports are open on both my server machine and my vpn but for some reason when someone chats my servers display these messages:

05/07/19 12:26 [RconCrossServerChat][error] Failed To Connect To Ark Server Rcon 147.135.94.171:32300 Error: 0, Trying again in 4 minute(s).
05/07/19 12:26 [RconCrossServerChat][error] Failed To Connect To Ark Server Rcon 147.135.94.171:32302 Error: 0, Trying again in 4 minute(s).
05/07/19 12:26 [RconCrossServerChat][error] Failed To Connect To Ark Server Rcon 147.135.94.171:32304 Error: 0, Trying again in 4 minute(s).

I had RCON working perfectly fine before the VPN, but I've also gone through the VPN and opened the ports...
 
Messages
2
Likes
0
Points
1
So i'm not sure what the issue is here, my ports are open on both my server machine and my vpn but for some reason when someone chats my servers display these messages:

05/07/19 12:26 [RconCrossServerChat][error] Failed To Connect To Ark Server Rcon 147.135.94.171:32300 Error: 0, Trying again in 4 minute(s).
05/07/19 12:26 [RconCrossServerChat][error] Failed To Connect To Ark Server Rcon 147.135.94.171:32302 Error: 0, Trying again in 4 minute(s).
05/07/19 12:26 [RconCrossServerChat][error] Failed To Connect To Ark Server Rcon 147.135.94.171:32304 Error: 0, Trying again in 4 minute(s).

I had RCON working perfectly fine before the VPN, but I've also gone through the VPN and opened the ports...
Hi I also get this error, the plugin is working but when I send messages there is a 30-35sec delay :(
 
Messages
2
Likes
0
Points
1
@Mortdredd350

Thanks man now the huge delay is gone but I keep getting Rcon error 0 in red color after each message I send in chat. If I send Hello in scorched I will get an Rcon error 0 in my SE Log but all my other server will get my message after like 0.5-1 sec. Same if my friend say Hello while playing on The Island I see his message after 0.5-1sec in Scorched but I will get an error on both servers SE and TI, I am getting this error only on servers with players, I own 6 clustered servers so if there is players in 4 of them and I say Hello in chat 4 servers will get the Rcon error 0 trying to reconnect in 1 min. Any solution for that error spam message?

Edit: All good, one of my server was not running this is why RCON was sending back an error 0
 
Last edited:

Wiing

New member
Messages
1
Likes
0
Points
1
Hi,

I have configured everything,
and the log show that it has loaded.

Is there any place i need to configure the login credentials like password to get it to work?
 
Top