Atlas Shop, Currency & Kits 1.0

No permission to download
Messages
5
Likes
0
Points
1
Apparently my config did not attach, this is regarding the post above!

"Hello, I recently opened up my server, and have been trying to successfully configure the plugin. I have got it working, HOWEVER, Anything that I have added to the config .json PAST The sample config posted here does not show up. I have added in SO MUCH extra stuff, but when I /shop only 3 things show up. I ran my .json through a validator and it said its valid... Unsure what would be causing it so that it doesn't show everything? Would someone be able to lend a hand??

I have attached my config, and a screenshot of what it shows in-game versus what my config has.

Thank you so much in advance!"
 

Attachments

Advertisement

Monetise Your Game Server

Want to monetise your ARK Server? Create your own webstore at tebex.io

patcher

Member
Donators
Messages
60
Likes
4
Points
8
Apparently my config did not attach, this is regarding the post above!

"Hello, I recently opened up my server, and have been trying to successfully configure the plugin. I have got it working, HOWEVER, Anything that I have added to the config .json PAST The sample config posted here does not show up. I have added in SO MUCH extra stuff, but when I /shop only 3 things show up. I ran my .json through a validator and it said its valid... Unsure what would be causing it so that it doesn't show everything? Would someone be able to lend a hand??

I have attached my config, and a screenshot of what it shows in-game versus what my config has.

Thank you so much in advance!"
Remove line 126 completely, add a comma to line 125, return line 993 and add }, to line 994 and you should be good
 
Messages
5
Likes
0
Points
1
So, got the shop working... kind of...

Whenever someone goes to buy something in the shop, it takes their points but does not give the item purchased. Any ideas on what would cause this? Current config attached.
 

Attachments

Revy

Member
Messages
32
Likes
7
Points
8
So the plugin doesnt create a DB for me. I set it up just like its ark brother but no DB is beeing created...
I am stuck at -97626676 Points...
 

Revy

Member
Messages
32
Likes
7
Points
8
No, I am using MySQL like I do with all plugins that support it.
I host my own Server. The crendtials are correct. its set to mysql = true and the db exists and the dbuser got the needed permissions.


The issue is: no db gets created, when i created the needed db myself (copied from ark and named to atlasshopplayers no entry gets created.
 

solax

New member
Messages
4
Likes
0
Points
1
Items aren't spawning but console command works, a snippet of my Kit JSON section is attached.

cheat giveitem "Blueprint'/Game/Mods/1632631187/Items/Weapon/PrimalItem_WeaponMetalHatchet_AP.PrimalItem_WeaponMetalHatchet_AP'" 1 0 0 will give the item. Which matches the blueprint path in the JSON.
 

Attachments

solax

New member
Messages
4
Likes
0
Points
1
Looking into it more - I'm able to redeem the kit (if free), but even with the points it will not reward items if paid. Thanks for any guidance you maybe able to offer!
 
Top