Atlas Shop, Currency & Kits 1.0

No permission to download

Haragon

Member
Plugin Developer
Donators
Messages
60
Likes
12
Points
8
I'm still waiting for all blueprints!
Copy and paste whats available in the wiki in to google sheets and you can knock out like 90% of them in one fell swoop. The rest is just crap that WC/GS and their disorganized selves threw in to random folders like "Test" and whatnot. But it's all out there.
 
Advertisement

Monetise Your Game Server

Want to monetise your ARK Server? Create your own webstore at tebex.io

saberene

New member
Messages
5
Likes
1
Points
3
Here is what i have already. I hope someone would be kind and maybe add some of there "working" pieces to the config. This works in game. Every item is spawning as it should. Im new to C++ this has been a learning experience for me. SO if it looks ugly My apologies. Ive got all Resources working and available for purchase a working starter kit with basic tools slightly above standard (Quality 1). A vip kit Which permissions have to be given for that includes a Draco spawn that lasts 3 hours and is level 20 tamed on use. It Does have a few tool blueprints and some plate armor and armor blueprints for purchase. Ive just about covered every example needed in this document to add pretty much anything you want. If someone has a set of scripted "dinos" already completed but didn't have resources it would be uber cool of you to share your work so as a community we can better the game at least a little bit.

Oh i forgot. This is currently Configured for Sql-lite, because I am on g-portal and its what is available for us to use.
 

Attachments

Last edited:

GeekGoggles

Member
Donators
Messages
128
Likes
10
Points
18
Copy and paste whats available in the wiki in to google sheets and you can knock out like 90% of them in one fell swoop. The rest is just crap that WC/GS and their disorganized selves threw in to random folders like "Test" and whatnot. But it's all out there.
Thanks for the kind words, I have been checking in on the wiki ;)
 

Bandit59007

New member
Donators
Messages
2
Likes
0
Points
1
Having an issue getting crew to spawn. it says it has been purchased and spawned, but no crew member has spawned at all when purchased. Here is my config file if anyone can figure it out and fix it. I did get the other items in the shop to spawn. Been spending the last few days trying to get it all working and this is the last step. TIA
 

Attachments

Messages
313
Likes
20
Points
18
Website
steamcommunity.com
Just a guess at this point, but I think a recent patch might have changed the BP path for the crew. I havent tested anything, but suddenly the vote rewards plugin is giving no reward fairly often... which could also be crew not spawning. Need to test spawning one of each in manually to ensure the path is correct.
 

Bandit59007

New member
Donators
Messages
2
Likes
0
Points
1
I managed to spawn one that wasnt tamed but when i used gmsummon to spawn a tamed one in, nothing.

I also checked the file paths and they are ok.

cheat spawndino "Blueprint'/Game/Atlas/Test/HumanNPC_BP_Crew_Male.HumanNPC_BP_Crew_Male'" 1 0 0 0

thats what i used and that one spawned in. but when i changed sp;awndino to gmsummon, nothing.

UPDATE: I did try this cheat gmsummon "humannpc_bp_crew_female_c" and it manually spawned in (added _c at the end). Then i added _c at the end of the path in the config.json, reloaded config, tried to buy npc female. nothing
 
Last edited:

ralohdesigns

New member
Donators
Messages
20
Likes
0
Points
1
This is what I used. I have not tested with PTR release.
"NPC1":{
"Type":"dino",
"Description":"Crew Female",
"Level":20,
"Price":25,
"MinLevel":1,
"MaxLevel":150,
"Blueprint":"Blueprint'/Game/Atlas/Test/HumanNPC_BP_Crew_Female.HumanNPC_BP_Crew_Female'"
},
"NPC2":{
"Type":"dino",
"Description":"Crew Male",
"Level":20,
"Price":25,
"MinLevel":1,
"MaxLevel":150,
"Blueprint":"Blueprint'/Game/Atlas/Test/HumanNPC_BP_Crew_Male.HumanNPC_BP_Crew_Male'"
},
 

Norlinri

New member
Messages
5
Likes
0
Points
1
@Michidu Ships bought with the config are set to ignore wind. Would it be possible to set the default command to "true true false" instead of "true true true"?

It's not possible to use the whole command in the shop, at least not with my testing as it doesn't pass with JSON Validator:

SpawnShip "Blueprint'/Game/Atlas/Vehicles/Ships/Galleon/Ship_BP_Galleon.Ship_BP_Galleon'" "Blueprint'/Game/Atlas/Structures/ShipHulls/ShipHullGalleon_BP.ShipHullGalleon_BP'" 10 true true false

If anyone managed to put ships that have everything but don't ignore wind (i.e. still need crew to man the sails and is affected by the wind), can you let me know? Thank you!
 
Last edited:
Messages
313
Likes
20
Points
18
Website
steamcommunity.com
@Michidu Ships bought with the config are set to ignore wind. Would it be possible to set the default command to "true true false" instead of "true true true"?

It's not possible to use the whole command in the shop, at least not with my testing as it doesn't pass with JSON Validator:

SpawnShip "Blueprint'/Game/Atlas/Vehicles/Ships/Galleon/Ship_BP_Galleon.Ship_BP_Galleon'" "Blueprint'/Game/Atlas/Structures/ShipHulls/ShipHullGalleon_BP.ShipHullGalleon_BP'" 10 true true false

If anyone managed to put ships that have everything but don't ignore wind (i.e. still need crew to man the sails and is affected by the wind), can you let me know? Thank you!
Thats not the whole story. All spawned ships ignore everything. They don't require crew to sail or shoot. And they don't agro anything. You would be better off making the purchase of a ship include all the parts to build it, rather than giving a ship.
 

Norlinri

New member
Messages
5
Likes
0
Points
1
Thats not the whole story. All spawned ships ignore everything. They don't require crew to sail or shoot. And they don't agro anything. You would be better off making the purchase of a ship include all the parts to build it, rather than giving a ship.
That's not exactly true. If you put false like I highlighted above, your spawned ship will require crew and will not ignore wind. Hence my question to Michidu :)
 

saberene

New member
Messages
5
Likes
1
Points
3
If in game.

cheat permissions.addgroup Premiums

Leave out Cheat If using Rcon.

To add a player to the group.

Cheat permissions.add "USERS STEAM 64" Premiums
 

Visual

Member
Donators
Messages
64
Likes
12
Points
8
When crew are purchased through my shop they are always spawning in "black", is there a reason why it's doing this? Some players think I'm doing it on purpose...
 
Messages
313
Likes
20
Points
18
Website
steamcommunity.com
Everything spawns black. And you are doing it on purpose. If you hadn't made the decision to make then available then they would have any at all. Buy them and use them, or do without! Stop letting your leaches dictate how you feel!
 

GGARK68

New member
Donators
Messages
1
Likes
0
Points
1
Hello. I wonder if it's going to give it as a / kit?
"plane":{
"Type":"ship",
"Description":"Plane",
"Price":2000,
"BlueprintShip":"Blueprint'/Game/Atlas/Devkit/Examples/Airplane/Aircraft_BP_Zephyr.Aircraft_BP_Zephyr'",
"BlueprintHull":"Blueprint'/Game/Atlas/Devkit/Examples/Airplane/ShipHull_BP_Hoopoe.ShipHull_BP_Hoopoe'"
}

it does not work

"Kits":{
"help":{
"DefaultAmount":20,
"Price":0,
"MinLevel":1,
"MaxLevel":151,
"Description":"Dzban wody oraz jedzenie",
"Items":[
{
"Amount":1,
"Quality":0,
"ForceBlueprint":false,
"Blueprint":"Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Consumables/PrimalItemConsumable_WaterJarRefill.PrimalItemConsumable_WaterJarRefill'"
},
{
"Amount":30,
"Quality":0,
"ForceBlueprint":false,
"Blueprint":"Blueprint'/Game/Atlas/AtlasCoreBP/Items/Recipes/PrimalItemConsumable_CookedMeat.PrimalItemConsumable_CookedMeat'"
}
]
},
"plane":{
"Permissions":"Default",
"DefaultAmount":2,
"Type":"ship",
"Description":"Samolot-Plane Uwazaj ma malo hp !!!",
"Price":0,
"BlueprintShip":"Blueprint'/Game/Atlas/Devkit/Examples/Airplane/Aircraft_BP_Zephyr.Aircraft_BP_Zephyr'",
"BlueprintHull":"Blueprint'/Game/Atlas/Devkit/Examples/Airplane/ShipHull_BP_Hoopoe.ShipHull_BP_Hoopoe'"
}
},
 
Messages
5
Likes
0
Points
1
Hello, I recently opened up my server, and have been trying to successfully configure the plugin. I have got it working, HOWEVER, Anything that I have added to the config .json PAST The sample config posted here does not show up. I have added in SO MUCH extra stuff, but when I /shop only 3 things show up. I ran my .json through a validator and it said its valid... Unsure what would be causing it so that it doesn't show everything? Would someone be able to lend a hand??

I have attached my config, and a screenshot of what it shows in-game versus what my config has.

Thank you so much in advance!
 

Attachments

Top