Atlas Permissions 1.5

No permission to download
Advertisement

Monetise Your Game Server

Want to monetise your ARK Server? Create your own webstore at tebex.io

KingMarcel

New member
Donators
Messages
7
Likes
0
Points
1
Hello, i setup an DB over Xamapp but every time I get the Error: Critical error, perm failed.
Config Settings:
{
"Database":"mysql",
"MysqlHost":"localhost",
"MysqlUser":"cencored",
"MysqlPass":"cencored",
"MysqlDB":"atlasperm",
"MysqlPort":cencored,
"DbPathOverride":""
}
 

dealtime

New member
Donators
Messages
6
Likes
0
Points
1
Hi,

First thanks for this amazing plugin,

Just want to know if we can deny command but accept the same in others ways to understand me :

I want few of my staff the possibilty to spawn Basic wood, basic tatch etc but deny them to spawn the others ressources.

Example :
Code:
ACCEPTED : admincheat giveitem "Blueprint'/Game/Atlas/AtlasCoreBP/Items/Resources/PrimalItemResource_Metal_BASE.PrimalItemResource_Metal_BASE'" 1 0 0

REFUSED : admincheat giveitem "Blueprint'/Game/Atlas/AtlasCoreBP/Items/Resources/PrimalItemResource_Metal_Copper.PrimalItemResource_Metal_Copper'" 1 0 0
It's the same command : giveitem
Can you add a new section with "Permissions.Deny STEAMID command",
I can enter every command one by one for every item I don't want to be spawned, it's not a problem.

Thanks alot
 
Messages
251
Likes
14
Points
18
Website
steamcommunity.com
So in the process of getting WoolyPenguins Discord integrator running, I found that I needed the Permission plug-in. Never had a need for it prior. Now when I add it, it locks up my server within about 30 seconds of joining.

Config is as follows. Anyone??

Code:
{
  "Database":"mysql",
  "MysqlHost":"x99.x35.2x2.1x8",
  "MysqlUser":"user",
  "MysqlPass":"pass",
  "MysqlDB":"atlasdiscord",
  "MysqlPort":3306,
  "DbPathOverride":""
}
 

GamingOGs

CEO | GamingOG's LLC
Donators
Messages
128
Likes
25
Points
18
Website
gamingogs.com
So in the process of getting WoolyPenguins Discord integrator running, I found that I needed the Permission plug-in. Never had a need for it prior. Now when I add it, it locks up my server within about 30 seconds of joining.

Config is as follows. Anyone??

Code:
{
  "Database":"mysql",
  "MysqlHost":"x99.x35.2x2.1x8",
  "MysqlUser":"user",
  "MysqlPass":"pass",
  "MysqlDB":"atlasdiscord",
  "MysqlPort":3306,
  "DbPathOverride":""
}
Need more info then just the config file.
1114 Code could imply it's MySQL database issue.
Something might not be set up on your server to support the discord config file.
Does it load? If so does it crash the server? Define lock up? Does it freeze? Does it unfreeze?
Bunch of variables that it could be and not enough information.
 
Messages
251
Likes
14
Points
18
Website
steamcommunity.com
The issue is, at this point, 100% this plugin. If its removed the server runs perfectly. If its added with that config it locks up. No crash, no crash report, nothing but a total seizure. It doesn't SEEM to happen until I connect though, and typically stays alive for 30-45 seconds before I lose connection to a time-out.

I deleted the database and created a new one. The plugin did create its two tables. It managed to record me in the players table, but didn't record me as an admin. I use the cheatID txt file.

EDIT: To add more to that story... The grid has sat empty since I posted the above. Joined just now and... client crash. Not a good test.
Joined again and... seems to be working fine now. Except all my crew are midgets!! WTF?!?! Now THATS hilarious!
 
Last edited:
Messages
251
Likes
14
Points
18
Website
steamcommunity.com
Another addition... restarted this grid to see if the success held and 34 seconds after joining the server restarted with no crash log. Basically closed to desktop. Server manager restarts on crash. Just for giggles I added fresh API and Plugin data to make sure nothing was screwed up there. Same result.
 
Last edited:
Messages
6
Likes
0
Points
1
helo,

can you please check up your basic permission functionality?
after the Atlas patch 1.5. seems it not working correct.

your plugin works and give response in chat, but the commands hooks has no effects.
i dont know is it a plugin problem or a atlas api 1.4


thx and best regards
Yukano
 
Top