Solved After installing ArkAPI server errors with [API][critical] Failed to detect game

maimedd

New member
Messages
4
Points
1
Hello,
After installing ArkAPI server errors with [API][critical] Failed to detect game. Also a popup saying The application was unable to start correctly, (0xc0000142) Click OK to close the application. I followed the video completely, and it does not want to launch. I can confirm after removing the API files the server starts correctly. I am on windows 10 (20'04). I do have VC installed. I installed the whole thing into the win64 folder. I have tested removing the plugins from the win64\arkapi\plugins and it still didnt launch.
 

Attachments

Advertisement

Official Game Server Partner

captkirk1993

Member
Donators
Messages
49
Points
8
Website
steamcommunity.com
Hello,
After installing ArkAPI server errors with [API][critical] Failed to detect game. Also a popup saying The application was unable to start correctly, (0xc0000142) Click OK to close the application. I followed the video completely, and it does not want to launch. I can confirm after removing the API files the server starts correctly. I am on windows 10 (20'04). I do have VC installed. I installed the whole thing into the win64 folder. I have tested removing the plugins from the win64\arkapi\plugins and it still didnt launch.
You have your servers within the ASM directory. This is incorrect! Please visit this thread and follow the install/setup directions.

After you've made the changes according to the setup instructions, then try to install and run ArkAPI.
 

WETBATMAN

Active member
Plugin Developer
Donators
Messages
297
Points
28
Website
dopeark.com
Hello,
After installing ArkAPI server errors with [API][critical] Failed to detect game. Also a popup saying The application was unable to start correctly, (0xc0000142) Click OK to close the application. I followed the video completely, and it does not want to launch. I can confirm after removing the API files the server starts correctly. I am on windows 10 (20'04). I do have VC installed. I installed the whole thing into the win64 folder. I have tested removing the plugins from the win64\arkapi\plugins and it still didnt launch.
your API folder is called arkapi it should be ArkApi instead, since it detects the game via folder name
 

maimedd

New member
Messages
4
Points
1
I am working on trying both changes, Moving server folder and I will change it to ArkApi.
 

maimedd

New member
Messages
4
Points
1
So I did both fixes at the same time, so I am unsure of which was the major issue, but thank you WETBATMAN and captkirk1993! It is now launching.
 

WETBATMAN

Active member
Plugin Developer
Donators
Messages
297
Points
28
Website
dopeark.com
So I did both fixes at the same time, so I am unsure of which was the major issue, but thank you WETBATMAN and captkirk1993! It is now launching.
what i pointed out was why your API wasn't detecting the game, what captkirk1993 refers to ASM and has nothing to do with the API, he told you to do this because having servers in the ASM directory pose a risk of them being deleted if ASM decides to update itself

hope this makes sense :)
 

maimedd

New member
Messages
4
Points
1
yep, It does, although when I moved the data, lost all the INI settings from asm, spent about 1.5 hours rebuilding that :( oh well, 99% back to normal, plugins working. Thanks again!
 

captkirk1993

Member
Donators
Messages
49
Points
8
Website
steamcommunity.com
yep, It does, although when I moved the data, lost all the INI settings from asm, spent about 1.5 hours rebuilding that :( oh well, 99% back to normal, plugins working. Thanks again!
You should have copied your data from old to new. If the old directories are there you could have done that after the fact.

Think about this...1.5 hours to rebuild your directory structures and ini settings or several hours completely rebuilding a server because it was wiped after an ASM update. And a high probability of having to do that each time ASM updates!
 
Top