Shop, Currency & Kits

Shop, Currency & Kits 2.8

No permission to download
Advertisement

Official Game Server Partner

tlk2drew

New member
Messages
12
Points
1
How do i stop kits from auto spawning on player spawn,?
as i would like them to be called in when needed.
in the .jaon file, under General, there is a section for "DefaultKit:". Delete the groups. Should look like

"DefaultKit": ""
 

Wade

New member
Messages
7
Points
1
on the bottom of the config u have the text formats of the plugin, you can delete the lines you dont want. For the points u can set it to 0 for all ranks... pretty simple.
So got that to work, HOW do i get rid of the Stone Axe/Pick, that seems to be coming from the Game its self, but cant find nothing in the ini files ?
 

highbass

Member
Messages
194
Points
18
It is impossible to make it work command:unlockengram in the shop it conflicts with the command: "" 's own quotes("") already.


"
unlockengram "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Structures/Misc/PrimalItemStructure_TekReplicator.PrimalItemStructure_TekReplicator'""
 

DW!

New member
Messages
19
Points
3
It is impossible to make it work command:unlockengram in the shop it conflicts with the command: "" 's own quotes("") already.


"
unlockengram "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Structures/Misc/PrimalItemStructure_TekReplicator.PrimalItemStructure_TekReplicator'""
This works fine, check your command line.

"tekengram":{
"Type":"unlockengram",
"Description":"Engram Tek Replicator",
"Price":20,
"Items":[
{
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Structures/Misc/PrimalItemStructure_TekReplicator.PrimalItemStructure_TekReplicator'"
}
]
},
 

highbass

Member
Messages
194
Points
18
This works fine, check your command line.

"tekengram":{
"Type":"unlockengram",
"Description":"Engram Tek Replicator",
"Price":20,
"Items":[
{
"Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Items/Structures/Misc/PrimalItemStructure_TekReplicator.PrimalItemStructure_TekReplicator'"
}
]
},
thank you! I completely missed out that part.
 

brentd

New member
Messages
2
Points
1
Currently broken does not get the right players steam ids and in the db it only shows 1 record and no commands work because the api cannot get the steam ids as its not getting and recording them to the database correctly any help please or is there a hotfix

-2305843009213693952 for the steam id

1604433021863.png
 

scorpions333z

New member
Messages
5
Points
1
Hi, I want to add premium how I do, thank you


"General": {
"TimedPointsReward": {
"Enabled": true,
"Interval": 10,
"Groups": {
"Default": {
"Amount": 2
},
"Premiums": {
"Amount": 4
 

Kristane

New member
Messages
6
Points
1
Currently broken does not get the right players steam ids and in the db it only shows 1 record and no commands work because the api cannot get the steam ids as its not getting and recording them to the database correctly any help please or is there a hotfix

-2305843009213693952 for the steam id

View attachment 3487
My server cluster is currently broken too when I've been running the cluster w/o issues for years. Now it seems the whole server population is sharing points from one account. Its the account that is chosen for the Bounty from the Bounty Hunter plugin. When I was the bounty I would see point rewards for killing troodons when I was in my base crafting. Then I found out that a different player was in the redwoods killing stuff and I was getting the rewards. However anyone was able to buy from the store as long as the points were there. We all showed the same point balance when all of us used /points. Any ideas?
 

V.UK

New member
Messages
25
Points
3
Yeah I use the re-worked one and have no issues with it at all. Some people have reported crashes but I have not experienced any at all. It's down to you ateotd which one you use ;-)
 

sleeper

New member
Messages
3
Points
1
Hi all!

I can't do the /trade command to work on my server. I have already reviewed the entire configuration, everything is ok. I looked for a solution here on the forum and didn't find any post about it. Can you help me? The server replies that there is no / trade command.

Code:
  "Messages":{ 
    "Sender":"Server do Povão",
    "BoughtItem":"<RichColor Color=\"0, 1, 0, 1\">Você comprou o item</>",
    "BoughtDino":"<RichColor Color=\"0, 1, 0, 1\">Você comprou o dino</>",
    "BoughtBeacon":"<RichColor Color=\"0, 1, 0, 1\">Você comprou o artefato</>",
    "BoughtExp":"<RichColor Color=\"0, 1, 0, 1\">Você comprou pontos de experiência</>",
    "ReceivedPoints":"<RichColor Color=\"1, 1, 0, 1\">Você recebeu {0} pontos! (total: {1})</>",
    "HavePoints":"Você tem {0} pontos",
    "NoPoints":"<RichColor Color=\"1, 0, 0, 1\">Você não tem pontos suficientes</>",
    "WrongId":"<RichColor Color=\"1, 0, 0, 1\">ID incorreto</>",
    "NoPermissionsKit":"<RichColor Color=\"1, 0, 0, 1\">Você não tem permissão para usar este kit</>",
    "CantBuyKit":"<RichColor Color=\"1, 0, 0, 1\">Você não pode comprar este kit</>",
    "BoughtKit":"<RichColor Color=\"0, 1, 0, 1\">Você comprou {0} kit</>",
    "AvailableKits":"Kits disponíveis para você:",
    "NoKits":"Não há kits disponíveis",
    "KitsLeft":"Você tem {0} {1} kits restantes",
    "NoKitsLeft":"Você não tem {0} kits restantes",
    "CantGivePoints":"<RichColor Color=\"1, 0, 0, 1\">Você não pode enviar pontos para você mesmo</>",
    "RidingDino":"<RichColor Color=\"1, 0, 0, 1\">Você não pode comprar este item montado em um dino</>",
    "SentPoints":"<RichColor Color=\"0, 1, 0, 1\">Você enviou {0} pontos para {1}</>",
    "GotPoints":"Você recebeu {0} pontos de {1}",
    "NoPlayer":"<RichColor Color=\"1, 0, 0, 1\">Player não existe</>",
    "FoundMorePlayers":"<RichColor Color=\"1, 0, 0, 1\">Encontrado mais de um player com o mesmo nome</>",
    "BuyUsage":"Use: /buy ID quantidade",
    "ShopUsage":"Use: /shop pagina",
    "KitUsage":"Use: /kit nome-do-kit",
    "BuyKitUsage":"Use: /BuyKit nome-do-kit quantidade",
    "TradeUsage":"Usage: /trade 'nome-do-player' quantidade",
    "PointsCmd":"/points",
    "TradeCmd":"/trade",
    "BuyCmd":"/buy",
    "ShopCmd":"/shop",
    "KitCmd":"/kit",
    "BuyKitCmd":"/buykit",
    "SellCmd":"/sell",
    "ShopSellCmd":"/shopsell",
    "SellUsage":"Usage: /sell id amount",
    "NotEnoughItems":"<RichColor Color=\"1, 0, 0, 1\">You don't have enough items ({0}/{1})</>",
    "SoldItems":"<RichColor Color=\"0, 1, 0, 1\">You have successfully sold items</>",
    "BadLevel":"<RichColor Color=\"1, 0, 0, 1\">Required level: {0} - {1}</>",
    "KitsListPrice":"Preço: {0}",
    "KitsListFormat":"\"{0}\" - {1}. {2} restante. {3}\n",
    "StoreListDino":"{0}) {1}. Level: {2}. Id: {3}. Preço: {4}\n",
    "StoreListItem":"{0}) {1}. Id: {2}. Preço: {3}\n",
    "StoreListFormat":"{0}",
    "OnlyOnSpawnKit":"Este kit só pode ser usado no spawn",
    "HelpCmd":"/shophelp",
    "ShopMessage":"Use: /buy ID quantidade",
    "HelpMessage":"This is shop help message"
  }
 

PedroArmindo

Member
Messages
59
Points
8
Website
www.youtube.com
Hi all!

I can't do the /trade command to work on my server. I have already reviewed the entire configuration, everything is ok. I looked for a solution here on the forum and didn't find any post about it. Can you help me? The server replies that there is no / trade command.

Code:
  "Messages":{
    "Sender":"Server do Povão",
    "BoughtItem":"<RichColor Color=\"0, 1, 0, 1\">Você comprou o item</>",
    "BoughtDino":"<RichColor Color=\"0, 1, 0, 1\">Você comprou o dino</>",
    "BoughtBeacon":"<RichColor Color=\"0, 1, 0, 1\">Você comprou o artefato</>",
    "BoughtExp":"<RichColor Color=\"0, 1, 0, 1\">Você comprou pontos de experiência</>",
    "ReceivedPoints":"<RichColor Color=\"1, 1, 0, 1\">Você recebeu {0} pontos! (total: {1})</>",
    "HavePoints":"Você tem {0} pontos",
    "NoPoints":"<RichColor Color=\"1, 0, 0, 1\">Você não tem pontos suficientes</>",
    "WrongId":"<RichColor Color=\"1, 0, 0, 1\">ID incorreto</>",
    "NoPermissionsKit":"<RichColor Color=\"1, 0, 0, 1\">Você não tem permissão para usar este kit</>",
    "CantBuyKit":"<RichColor Color=\"1, 0, 0, 1\">Você não pode comprar este kit</>",
    "BoughtKit":"<RichColor Color=\"0, 1, 0, 1\">Você comprou {0} kit</>",
    "AvailableKits":"Kits disponíveis para você:",
    "NoKits":"Não há kits disponíveis",
    "KitsLeft":"Você tem {0} {1} kits restantes",
    "NoKitsLeft":"Você não tem {0} kits restantes",
    "CantGivePoints":"<RichColor Color=\"1, 0, 0, 1\">Você não pode enviar pontos para você mesmo</>",
    "RidingDino":"<RichColor Color=\"1, 0, 0, 1\">Você não pode comprar este item montado em um dino</>",
    "SentPoints":"<RichColor Color=\"0, 1, 0, 1\">Você enviou {0} pontos para {1}</>",
    "GotPoints":"Você recebeu {0} pontos de {1}",
    "NoPlayer":"<RichColor Color=\"1, 0, 0, 1\">Player não existe</>",
    "FoundMorePlayers":"<RichColor Color=\"1, 0, 0, 1\">Encontrado mais de um player com o mesmo nome</>",
    "BuyUsage":"Use: /buy ID quantidade",
    "ShopUsage":"Use: /shop pagina",
    "KitUsage":"Use: /kit nome-do-kit",
    "BuyKitUsage":"Use: /BuyKit nome-do-kit quantidade",
    "TradeUsage":"Usage: /trade 'nome-do-player' quantidade",
    "PointsCmd":"/points",
    "TradeCmd":"/trade",
    "BuyCmd":"/buy",
    "ShopCmd":"/shop",
    "KitCmd":"/kit",
    "BuyKitCmd":"/buykit",
    "SellCmd":"/sell",
    "ShopSellCmd":"/shopsell",
    "SellUsage":"Usage: /sell id amount",
    "NotEnoughItems":"<RichColor Color=\"1, 0, 0, 1\">You don't have enough items ({0}/{1})</>",
    "SoldItems":"<RichColor Color=\"0, 1, 0, 1\">You have successfully sold items</>",
    "BadLevel":"<RichColor Color=\"1, 0, 0, 1\">Required level: {0} - {1}</>",
    "KitsListPrice":"Preço: {0}",
    "KitsListFormat":"\"{0}\" - {1}. {2} restante. {3}\n",
    "StoreListDino":"{0}) {1}. Level: {2}. Id: {3}. Preço: {4}\n",
    "StoreListItem":"{0}) {1}. Id: {2}. Preço: {3}\n",
    "StoreListFormat":"{0}",
    "OnlyOnSpawnKit":"Este kit só pode ser usado no spawn",
    "HelpCmd":"/shophelp",
    "ShopMessage":"Use: /buy ID quantidade",
    "HelpMessage":"This is shop help message"
  }

Ta usando /trade <'CharacterName'> <Amount> corretamente?
exemplo: /trade 'Pedro' 10
 

sleeper

New member
Messages
3
Points
1
Ta usando /trade <'CharacterName'> <Amount> corretamente?
exemplo: /trade 'Pedro' 10
Sim Pedro, ele simplesmente diz que o comando não existe no servidor. COmo se eu digitasse o comando errado. Tentei trocar para /comercio, mas também não vai.
 
Top