Shop, Currency & Kits

Shop, Currency & Kits 2.8

No permission to download

TheAmyey

New member
Messages
1
Points
1
I'm having trouble starting my server and keep getting this
[json.exception.type_error.305] cannot use operator[] with null
Can somebody help me out?
 

Attachments

Last edited:
Advertisement

Official Game Server Partner

Dielen1

New member
Messages
1
Points
1
Is there any possibility to adjust the color of the ''kitlist'' ''shoppages'' (which is now green). I can only find how to adjust the size of the text.
 

Rumaan

New member
Messages
27
Points
3
The file looks okay at a quick glance, and it does validate through a JSON checker. Can you see the CMD window when your server is starting? If so, does the Shop API actually load? Another thing you can do is try to restart your server to make sure it loads the file, or run the command when you are actually in game.
 

bisurmanin

New member
Messages
2
Points
1
The file looks okay at a quick glance, and it does validate through a JSON checker. Can you see the CMD window when your server is starting? If so, does the Shop API actually load? Another thing you can do is try to restart your server to make sure it loads the file, or run the command when you are actually in game.
Thanks for reply. To resolve i must connect it with outside database (i use free database). For others i paste working file with ARK:SE vanilla server.
 

Attachments

LupeCZ

New member
Messages
5
Points
1
JSON:
    "Kits": {
        "vip": {
            "DefaultAmount": 1,
            "Description": "5x Heavies and 1500 ammo",
            "Price": 200, 
            "Permissions": "vip",
            "Items": [
                {
                    "Amount": 5,
                    "Quality": 0,
                    "ForceBlueprint": false,
                    "Blueprint": "Blueprint'/Game/Mods/StructuresPlusMod/Misc/AutoTurretHeavy/PrimalItemStructure_AutoTurret_Heavy.PrimalItemStructure_AutoTurret_Heavy'"
                },
                {
                    "Amount": 1500,
                    "Quality": 0,
                    "ForceBlueprint": false,
                    "Blueprint": "Blueprint'/Game/PrimalEarth/CoreBlueprints/Weapons/PrimalItemAmmo_AdvancedRifleBullet.PrimalItemAmmo_AdvancedRifleBullet'"
                }
            ]
        }

    },
Hello, I have ark shop and ark permission. I made vip Kit for vips, there is group called "vip" in permission plugin, player has this group applied but ArkShop dont allow him to get Kit...
Can someone please tell me how to fix it?
 

Rumaan

New member
Messages
27
Points
3
Hello, I have ark shop and ark permission. I made vip Kit for vips, there is group called "vip" in permission plugin, player has this group applied but ArkShop dont allow him to get Kit...
Can someone please tell me how to fix it?
You need to edit the General section and add that as a group in the config if you have not done so:

"General":{
"TimedPointsReward":{
"Enabled":true,
"Interval":5,
"Groups":{
"Default":{ "Amount":5 },
"vip":{ "Amount":15 } // <----- This one here. Edit the points as you want.
} },

any one able to help with permissions for my config it says i dont have permissions to use the kit when loded in game
You have a similar issue. Make sure to actually add the groups you want into the Shop config file. And since you didn't mention it, make sure you are added to those groups in the Permissions API.

This is my best guess, not knowing much about your setups.
 

ArkPark

New member
Messages
3
Points
1
How can i sincronizate all points in a same data from a cluster ( 3 servers ) ? ( Same points in all servers )
 

Rumaan

New member
Messages
27
Points
3

CondoARK

New member
Messages
4
Points
1
Hi Michidu,
Love the ArkShop, I'm running a cluster server, have updated the db path, added things to the config, etc. All seems fine but points are not "coming with you" when you transfer between servers. In other words, when on valguero I have say 850 points, but on Crystal Isles I have only 300 points. Also, when buying kits, etc. it's not keeping the stuff between servers or deaths. For example, pay for "All Engrams" and it removes your points, gives you all engrams as it should, but as soon as you die or transfer between servers, it's gone. I'll attach my config file.
 

Attachments

CondoARK

New member
Messages
4
Points
1
Hi Michidu,
Love the ArkShop, I'm running a cluster server, have updated the db path, added things to the config, etc. All seems fine but points are not "coming with you" when you transfer between servers. In other words, when on valguero I have say 850 points, but on Crystal Isles I have only 300 points. Also, when buying kits, etc. it's not keeping the stuff between servers or deaths. For example, pay for "All Engrams" and it removes your points, gives you all engrams as it should, but as soon as you die or transfer between servers, it's gone. I'll attach my config file.
Short Update: The person I asked said it wasn't working, upon testing, that is not true. So the only issue I have is how do they keep engrams, etc. when transferring back and forth on Clustered Servers or losing them when you die.
 

CondoARK

New member
Messages
4
Points
1
How can i sincronizate all points in a same data from a cluster ( 3 servers ) ? ( Same points in all servers )
You can edit the db path in the config.json file. Just put the path in the "". For example, If you have c:\ArkShop\ArkShop.db, you enter it in your config file to look like this...

"DbPathOverride":"C:\\ArkShop\\ArkShop.db",

You need to edit each config.json if your using different configs like I do. I just edit one and I've created a batch file that copies the config.json to my other servers file locations after I test it on the first server.
 

twobrotherzzh

New member
Messages
20
Points
3
This is the tool I wrote to edit the ArkShop configuration. You can try it
1595570003111.png1595570326953.png1595569898615.png1595569910940.png
 
Last edited:

Ivellos

New member
Messages
3
Points
1
For some reason if someone is part of multiple groups. Ark Shop seems to go to the lowest group available, other than default, this makes it hard to give correct rewards to someone. Maybe I am doing something wrong but any suggestions would be awesome.

For example. I am having anyone who links their discord get extra points because they have the in game discord permissions. However if they also supported the server they also have a donator group that would technically give them more points. However it seems to only ever reward the discord points vs the donator ones.

thanks!
 

DaDekker

New member
Messages
1
Points
1
I am getting this problem where any commands that involves in Steam ID does not work, if i use addpoints system it said's couldn't add points, and when i gave myself permission group vip i cant access it, i can only stay default and buy item and nothing else of the other commands work
 
Top