Question Shop,Currency&Kits commands not working / plugin not loading?

Riiloo

New member
Messages
14
Points
1
Hello,

I have an issue getting ArkShop to work on my server, I can't tell whether the commands are just not working, or the plugin itself is not working.

I've installed it exactly how I've installed the other plugins I have through FTP (FileZilla), the other plugins work fine, it's just ArkShop.
I've done plugins.load ArkShop to see if it would load it, I've done ArkShop.reload to see if it would reload the conifg, but to no avail.

Is it something to do with my config file, or is it just not installed right some how?

I went to check the configuration that I've setup on JSONLint (https://jsonlint.com/) and I corrected some errors that it detected, the only one left is the last line


1617099029521.png


Seeing how it was just part of the end of the config, and its there in the default ArkShop config, I left it as it is, I copied and pasted the edited JSON file into a Notepad++ sheet, and the config is a little odd placed, the { and [ are joined in some times on one line where it should be seperate lines, and the entire config is basically shifted right more.
Down below is two parts of my config files, one of my own edit from the JSONLint edit, where I re-did the lines and all, and one with just the JSONLint edit so the difference can be seen.

config(JSONLint).txt

config(myedit).txt


I'll also send in my full config file, this is the first time I've written full config and lines before with [ { and where to place them, I mostly followed the default config and tried to follow the existing lines of where the [ and { were located. This is the full re-edit of the JSONLint Edited config file.

config.json


If anyone knows what could be causing ArkShop from not working when other plugins work, it would be great if any help can be provided, whether its the config I've made or my stupidity on installing it wrong or whatever.

Cheers,



P.S If the config files look the same, or are unchanged, try opening them in Notepad++ as thats where I saw the difference, if still nothing ill send a Screenshot of the two.
P.P.S unless it doesn't matter where the [ and { sit in the config, does the server, or file, auto align them?

-- Edit -- I don't know why the first two files are .txt instead of .json
 

Attachments

Advertisement

Official Game Server Partner

Foppa

Administrator
Staff member
Messages
1,028
Points
63
Website
foppasgaming.com
Hello,

I have an issue getting ArkShop to work on my server, I can't tell whether the commands are just not working, or the plugin itself is not working.

I've installed it exactly how I've installed the other plugins I have through FTP (FileZilla), the other plugins work fine, it's just ArkShop.
I've done plugins.load ArkShop to see if it would load it, I've done ArkShop.reload to see if it would reload the conifg, but to no avail.

Is it something to do with my config file, or is it just not installed right some how?

I went to check the configuration that I've setup on JSONLint (https://jsonlint.com/) and I corrected some errors that it detected, the only one left is the last line


View attachment 4037


Seeing how it was just part of the end of the config, and its there in the default ArkShop config, I left it as it is, I copied and pasted the edited JSON file into a Notepad++ sheet, and the config is a little odd placed, the { and [ are joined in some times on one line where it should be seperate lines, and the entire config is basically shifted right more.
Down below is two parts of my config files, one of my own edit from the JSONLint edit, where I re-did the lines and all, and one with just the JSONLint edit so the difference can be seen.

config(JSONLint).txt

config(myedit).txt


I'll also send in my full config file, this is the first time I've written full config and lines before with [ { and where to place them, I mostly followed the default config and tried to follow the existing lines of where the [ and { were located. This is the full re-edit of the JSONLint Edited config file.

config.json


If anyone knows what could be causing ArkShop from not working when other plugins work, it would be great if any help can be provided, whether its the config I've made or my stupidity on installing it wrong or whatever.

Cheers,



P.S If the config files look the same, or are unchanged, try opening them in Notepad++ as thats where I saw the difference, if still nothing ill send a Screenshot of the two.
P.P.S unless it doesn't matter where the [ and { sit in the config, does the server, or file, auto align them?

-- Edit -- I don't know why the first two files are .txt instead of .json
You have tons of errors in your config. Wrong side of brackets, and your closing the wrong sections.
Basically how you want to see the config as this:


JSON:
{
  "Mysql":{ 
    // MySQL Section
  }, 
  "General":{ 
    // General Section
  },
  "Kits":{ 
    // Kits Section
  },
  "ShopItems":{ 
    // Shop Section
  },
  "SellItems":{ 
    // Sell Section
  },
  "Messages":{ 
    // Message Section
  }
}
 

Riiloo

New member
Messages
14
Points
1
Thanks for the reply,

I've made some changes to where 2 different JSON sites now say its valid,
I put it into the config file on the server, did cheat ArkShop.Reload as well as cheat plugins.reload ArkShop

It now comes up in the in game chat saying
"(SERVER): Failed to load plugin - Failed to load plugin - ArkShop
Error Code: 1114"

-----------------------------------------
Editing onto post while making it just to note what has happened

I looked up Error Code 1114 and someone said to put

"Kits":{
},


I put that in and reloaded the plugin, and it worked successfully, except when I do /kit, it doesn't show any kits.

-----------------------------------------

Another issue is some of the chat commands don't do anything, and I think its only the commands to do with points, e.g /points and /trade
I tried adding 15 points to my steamID but it said in chat in red "(SERVER): Couldn't add points"

I've attached what the first section of the JSON looks like now, with the start and upto the first kit

config(points+kits).txt

JSONLint and jsonformatter.curiousconcept both say the entire JSON is valid, I'm just assuming some things are in the wrong places still :/ I've tried looking how to fix but I can't wrap my head around it to see what I'm missing or doing wrong.
 

Attachments

Pelayori

Active member
Plugin Developer
Donators
Messages
151
Points
28
Thanks for the reply,

I've made some changes to where 2 different JSON sites now say its valid,
I put it into the config file on the server, did cheat ArkShop.Reload as well as cheat plugins.reload ArkShop

It now comes up in the in game chat saying
"(SERVER): Failed to load plugin - Failed to load plugin - ArkShop
Error Code: 1114"

-----------------------------------------
Editing onto post while making it just to note what has happened

I looked up Error Code 1114 and someone said to put

"Kits":{
},


I put that in and reloaded the plugin, and it worked successfully, except when I do /kit, it doesn't show any kits.

-----------------------------------------

Another issue is some of the chat commands don't do anything, and I think its only the commands to do with points, e.g /points and /trade
I tried adding 15 points to my steamID but it said in chat in red "(SERVER): Couldn't add points"

I've attached what the first section of the JSON looks like now, with the start and upto the first kit

config(points+kits).txt

JSONLint and jsonformatter.curiousconcept both say the entire JSON is valid, I'm just assuming some things are in the wrong places still :/ I've tried looking how to fix but I can't wrap my head around it to see what I'm missing or doing wrong.
Kits need to be inside "Kits":{
so remove that "Kits": {}, and change it for

"Kits":{
// Here you put kits
}
 

ProjectRoot

Member
Messages
42
Points
8
Thanks for the reply,

I've made some changes to where 2 different JSON sites now say its valid,
I put it into the config file on the server, did cheat ArkShop.Reload as well as cheat plugins.reload ArkShop

It now comes up in the in game chat saying
"(SERVER): Failed to load plugin - Failed to load plugin - ArkShop
Error Code: 1114"

-----------------------------------------
Editing onto post while making it just to note what has happened

I looked up Error Code 1114 and someone said to put

"Kits":{
},


I put that in and reloaded the plugin, and it worked successfully, except when I do /kit, it doesn't show any kits.

-----------------------------------------

Another issue is some of the chat commands don't do anything, and I think its only the commands to do with points, e.g /points and /trade
I tried adding 15 points to my steamID but it said in chat in red "(SERVER): Couldn't add points"

I've attached what the first section of the JSON looks like now, with the start and upto the first kit

config(points+kits).txt

JSONLint and jsonformatter.curiousconcept both say the entire JSON is valid, I'm just assuming some things are in the wrong places still :/ I've tried looking how to fix but I can't wrap my head around it to see what I'm missing or doing wrong.
I can help you with the config, i also provided a very detailed guide for this plugin in the host i been using for years, https://www.activegamehost.com/client/knowledgebase/74/-Ark-Shop-Currency-and-Kits-Plugin.html should you wish to take a look at it, or hit me up on discord Root#8971 , im more than happy to guide you step by step and teaching you
 

Riiloo

New member
Messages
14
Points
1
I can help you with the config, i also provided a very detailed guide for this plugin in the host i been using for years, https://www.activegamehost.com/client/knowledgebase/74/-Ark-Shop-Currency-and-Kits-Plugin.html should you wish to take a look at it, or hit me up on discord Root#8971 , im more than happy to guide you step by step and teaching you
Hello Project, while I thank you heaps for the offered support, I've gotten it working by using a auto JSON editor as well as a ArkShop JSON Generator. I've looked at where the sections start, meet and end, how items and kits are added, and have started to learn to just writing them properly without issues now, cheers for the help though! I can provide the links of those two if you or anyone wants to use em
 
Top