Bug Several crashes in the last few days

trevorjd

New member
Messages
17
Points
1
Hi,

We run 3 Ark instances on a Windows 2016 dedi so which we only have RDP access. We've had a few crashes in the last 4-5 days that I haven't been able to pin down yet.
We've made no mod changes although S+ has updated at least twice. I don't recall if there's been a base game update in this period.

Three instances run within TCAdmin and I have a fourth instance in ArkServerManager for testing. I updated supply drop loot tables and tested in the ASM instance and that was OK for a few hours but then the three production instances all stopped responding at once. I downed the ASM instance and things seemed stable for a day or two. Then, around 5pm, all three TCAdmin instances stopped responding again. We restarted and 5 hours later, it happened again. This time, I found a crash dialog waiting for me on RDP that points to ArkServerAPI.

I don't understand enough about Ark or ArkAPI to read this crash dialog. Is there anything that can be done? Thanks!

Image:
 
Advertisement

Official Game Server Partner

sirshaw

ArkBot Project Lead
Donators
Messages
43
Points
8
Website
WWW.KNIGHTSGG.COM
From the crash dialog, it’s definitely being caused by something in the ark server api. From the looks of it, something to do with a timer. What I would do is 1. Remove S+ from the startup. 2. Make sure you have the latest versions of all your plugins/API. 3. Remove all plugins and add one at a time until you see the server crash again. I would always start with the knowns. You know s+ updated and the server started being unstable shortly after. If you do all those things I’ve outlined, you should find your cause.
 

Lethal

Active member
Plugin Developer
Messages
364
Points
43
Advanced Chat is causing the crash and most likely something in the code gets stuck in an infinite loop is my guess.
 

M8810

New member
Messages
2
Points
1
@trevorjd we had the same problems the last few weeks, switched to the mod SuperStructures (SS), since then we no longer have these problems. The S.
+ mod unfortunately just brings too many problems (in our opinion). The config is the same, only the header [StructuresPlus] has to be changed to [SuperStructures]. Most of the structures remain, missing were for example glass cliff platform. Since we changed, the servers run without exception (8 maps). We have over 10 plugins and have not encountered any problems in this regard, except for the initial server startup with a CrossChat plugin (snapshot problems).
 

trevorjd

New member
Messages
17
Points
1
Thanks all. Removing S+ is simply not an option for our production servers. Replacing it with SS *may* be an option although I suspect we have several people who've built with glass platforms! Thanks for the suggestion there. AdvChat is the only plugin present. For now, I deleted the ASA folder and reinstalled ASA and AdvChat from scratch. It's been OK for 15 hrs.

I've PM'd the AdvChat author via Discord and hoping they'll be able to help with activating diagnostics to track the problem down.
 

M8810

New member
Messages
2
Points
1
ok i can understand that. A change in the middle of the season is indeed difficult. But for the future I can only recommend it. The build also works properly with it, the things snap in as they should and not somewhere in the ground or somewhere else :D. All the best ;)
 
Top