ARK: Server API

ARK: Server API 3.53

No permission to download
1111.png
ArkApi is a plugin which allows you to create your own server-side plugins for ARK using C++ language.

Installation:
  1. Extract everything to "ARK\ShooterGame\Binaries\Win64". All files like "version.dll" should be in "Win64" folder.
  2. Start your ARK server as usual.
Video instruction:

If everything went correctly, you will see something like this in the server console:
ArkApi.png


Installing new plugins:
  1. Download plugin.
  2. Copy plugins folder to "ARK\ShooterGame\Binaries\Win64\ArkApi\Plugins". Example: "ArkApi\Plugins\ArkShop".
  3. Start or restart your server. Alternatively, you can load plugin without restarting the server by using commands provided in this thread: https://arkserverapi.com/threads/faq.5/.
Requirements:
Logs:
Logs created by ArkApi can be found in 'ShooterGame/Win64/logs/ArkApi.log'.​
Dumps and crash logs can be found in 'ShooterGame/Saved/Logs/'.​
Plugins:

If you have any questions, read our FAQ first.
Author
Pelayori
Downloads
330,642
Views
330,642
First release
Last update
Rating
4.97 star(s) 32 ratings

More resources from Pelayori

  • GenderChanger
    GenderChanger
    Change gender of dinos with a command and configurable token system & permissions
  • Cross Server Chat
    Cross Server Chat
    Player chat across ark servers, Supports Unicode
  • Cross Server Chat
    Cross Server Chat
    Player chat across ark servers, Supports Unicode
  • Mission Disabler
    Mission Disabler
    Disable certain missions (Gen2 & other maps)
  • SafeZones
    SafeZones
    Protect Area's from pvp, building & add notifications, changes spawn point

Latest updates

  1. 3.53

    Implemented tick/timer crash fix (for those referencing crashes from Hook_UWorld_Tick, or...
  2. 3.52

    Fixed high RAM usage
  3. 3.51

    Updated PDB Reader to fix crashes brought by latest ark versions (deflate, addler, compress...

Latest reviews

You can make a < dark and ligt >Dnl api
They are very much alike
thank you
wie komme ich zu einer älteren version die neue funktioniert laut Gportal nicht mehr mit ark
al parecer algunos plugin probocan problemas en las 3.53 api verifiquen eso porfa los plugin de kal por ejemplo
Pelayori
Pelayori
This is not a bug in the api itself, please refer to the plugin developer if you are having any issue.
Any chance of a linux version in the future?
Good Work, only the Permissions Plugin inside the Pluginsfolder are old, they should be deleted!
非常好
This makes it all happen. Easiest 5 star on this entire site.
Amazing!
Thanks a lot!!!
Can I use this after starting the server?
People are already playing and building up
Great work!
Top